92 Packages in sys-libs

Portage Tree » sys-libs

Click the package name to view details, versions available and change logs.

template based math library, written in C++, for symbolic and numeric calculus applications - Versions: (GPL-2)
-v3
Compatibility package for binaries linked against a pre gcc 3.4 libstdc++ - Versions: 3.3.6-r1 (GPL-2 LGPL-2.1)
-v3-bin
Compatibility package for running binaries linked against a pre gcc 3.4 libstdc++ - Versions: 3.3.6 (GPL-2 LGPL-2.1)
argp-standalone
Standalone argp library for use with uclibc - Versions: 1.3-r2 (public-domain)
binutils-libs
Core binutils libraries (libbfd, libopcodes, libiberty) for external packages - Versions: 2.25.1-r2, 2.29.1-r1, 2.28.1, 2.27 (|| ( GPL-3 LGPL-3 ))
compiler-rt
Compiler runtime library for clang (built-in part) - Versions: 5.0.0, 4.0.1, 5.0.9999, 9999 (|| ( UoI-NCSA MIT ))
compiler-rt-sanitizers
Compiler runtime libraries for clang (sanitizers & xray) - Versions: 9999, 4.0.1, 5.0.0, 5.0.9999 (|| ( UoI-NCSA MIT ))
cracklib
Password Checking Library - Versions: 2.9.6-r1 (LGPL-2.1)
csu
Darwin Csu (crt1.o) - Mac OS X 10.6.6 to 10.9.5 versions - Versions: 79, 85 (APSL-2)
cygwin-crypt
Cygwin Encryption/Decryption utility and library - Versions: 1.4 (GPL-2+)
db
Oracle Berkeley DB - Versions: 5.3.28-r2, 6.1.29, 5.3.28-r3, 4.5.20_p2-r1, 6.1.29-r1, 4.2.52_p5-r1, 6.0.35, 4.3.29_p1-r1, 6.2.23, 6.2.32, 3.2.9_p2, 4.4.20_p4-r1, 6.2.32-r1, 1.85-r3, 4.8.30-r2, 5.1.29-r1, 4.6.21_p4, 4.7.25_p4, 6.0.35-r1, 6.2.23-r1 (Sleepycat)
e2fsprogs-libs
e2fsprogs libraries (common error and subsystem) - Versions: 1.43.6, 1.43.7, 1.43.3 (GPL-2)
efivar
Tools and library to manipulate EFI variables - Versions: 31, 30 (GPL-2)
fortify-headers
A standalone implementation of fortify source. - Versions: 0.7, 0.6, 9999 (ISC)
freeipmi
Provides Remote-Console and System Management Software as per IPMI v1.5/2.0 - Versions: 1.4.8, 1.2.2, 1.5.6, 1.5.7, 1.4.3 (GPL-3)
fts-standalone
Standalone fts library for use with musl - Versions: 0.2-r1, 1.2.7 (BSD)
gdbm
Standard GNU database libraries - Versions: 1.12, 1.13-r1, 1.11, 1.13 (GPL-3)
glibc
GNU libc6 (also called glibc2) C library - Versions: 2.25-r8, 2.23-r3, 2.19-r1, 9999, 2.21-r2, 2.24-r4, 2.22-r4, 2.18-r1, 2.17, 2.25-r9, 2.23-r4, 2.20-r2, 2.26-r3 (LGPL-2.1+ BSD HPND ISC inner-net rc PCRE)
gpm
Console-based mouse driver - Versions: 1.20.7-r2 (GPL-2)
gwenhywfar
A multi-platform helper library for other libraries - Versions: 4.15.3, 4.15.3-r1, 4.13.1, 4.12.0_beta, 4.3.3 (LGPL-2.1)
kpmcore
Library for managing partitions - Versions: 3.2.1 (GPL-3)
ldb
An LDAP-like embedded database - Versions: 1.1.29-r1, 1.3.0, 1.2.2, 1.1.26, 1.1.31 (LGPL-3)
lib-compat
Compatibility C++ library for very old programs - Versions: 1.5, 1.4.2-r1 (libstdc++)
lib-compat-loki
Compatibility libc6 libraries for Loki games - Versions: 0.2-r1 (GPL-2)
libaal
library required by reiser4progs - Versions: 1.0.5-r1, 1.0.5, 1.0.6 (GPL-2)
libapparmor
Library to support AppArmor userspace utilities - Versions: 2.11.1 (LGPL-2.1)
libavc1394
library for the 1394 Trade Association AV/C (Audio/Video Control) Digital Interface Command Set - Versions: 0.5.4, 0.5.3, 0.5.4-r1 (LGPL-2.1)
libblockdev
A library for manipulating block devices - Versions: 2.13, 2.14 (LGPL-2+)
libcap
POSIX 1003.1e capabilities - Versions: 2.25, 2.24-r2 (|| ( GPL-2 BSD ))
libcap-ng
POSIX 1003.1e capabilities - Versions: 0.7.8 (LGPL-2.1)
libchipcard
Libchipcard is a library for easy access to chip cards via chip card readers (terminals) - Versions: 5.0.2 (LGPL-2.1)
libcxx
New implementation of the C++ standard library, targeting C++11 - Versions: 5.0.0, 3.9.1, 3.8.1, 3.7.1, 3.9.0, 4.0.1, 9999, 5.0.9999 (|| ( UoI-NCSA MIT ))
libcxxabi
Low level support for a standard C++ library - Versions: 4.0.1, 3.9.1, 3.9.0, 9999, 5.0.0, 5.0.9999 (|| ( UoI-NCSA MIT ))
libcxxrt
C++ Runtime from PathScale, FreeBSD and NetBSD - Versions: 9999, 0.0_p20140322, 0.0_p20170515, 0.0_p20150423-r1, 0.0_p20160922 (BSD-2)
libfaketime
Report faked system time to programs - Versions: 0.9.6-r2, 0.9.6-r1 (GPL-2)
libhugetlbfs
easy hugepage access - Versions: 2.19, 2.19-r1, 2.18, 2.20 (GPL-2)
libhx
Platform independent library providing basic system functions - Versions: 3.22, 3.22-r1, 3.16 (GPL-3)
libieee1284
Library to query devices using IEEE1284 - Versions: 0.2.11-r6, 0.2.11-r4, 0.2.11-r5 (GPL-2)
libixp
A stand-alone client/server 9P library including ixpc client - Versions: 0.5_p20110208-r3 (MIT)
libkudzu
Red Hat Hardware detection tools - Versions: 1.2.57.1 (GPL-2)
libnih
Light-weight 'standard library' of C functions - Versions: 1.0.3-r3 (GPL-2)
libomp
OpenMP runtime library for LLVM/clang compiler - Versions: 5.0.9999, 3.7.1, 9999, 3.9.0, 4.0.1, 3.8.1, 3.9.1, 5.0.0 (|| ( UoI-NCSA MIT ) MIT LLVM-Grant)
libosinfo
GObject library for managing information about real and virtual OSes - Versions: 1.0.0, 1.0.0-r1 (GPL-2 LGPL-2.1)
libraw1394
library that provides direct access to the IEEE 1394 bus - Versions: 2.1.2, 2.1.1, 2.1.0-r1 (LGPL-2.1)
librtas
A set of libraries for userspace access to RTAS on the PowerPC platform(s) - Versions: 1.3.8, 1.3.6, 1.3.13 (IBM)
libseccomp
high level interface to Linux seccomp filter - Versions: 2.3.0, 2.3.1, 2.3.2 (LGPL-2.1)
libselinux
SELinux userland library - Versions: 2.6, 9999, 2.7 (public-domain)
libsemanage
SELinux kernel and policy management library - Versions: 2.7, 9999, 2.6 (GPL-2)
libsepol
SELinux binary policy representation library - Versions: 2.6, 2.7, 9999 (GPL-2)
libservicelog
Provides a library for logging service-related events - Versions: 1.1.15, 1.1.11, 1.1.16, 1.0.1 (IBM)
libsmbios
Provide access to (SM)BIOS information - Versions: 2.3.0-r1, 2.3.3, 2.3.2 (GPL-2 OSL-2.0)
libspe2
A wrapper library to adapt the JSRE SPU usage model to SPUFS - Versions: 2.2.80_p95-r1, 2.3.0_p135 (LGPL-2)
libstatgrab
A tool to provide access to statistics about the system on which it's run - Versions: 0.91, 0.17 (|| ( GPL-2 LGPL-2.1 ))
libtermcap-compat
Compatibility package for old termcap-based programs - Versions: 2.0.8-r2, 2.0.8-r3, 2.0.8-r4 (GPL-2 LGPL-2 BSD)
libudev-compat
Wrapper around libudev.so.1 for packages needing the old libudev.so.0 - Versions: 186 (LGPL-2.1+)
libunwind
Portable and efficient API to determine the call-chain of a program - Versions: 1.2.1, 1.1-r1, 1.2 (MIT)
libutempter
Library that allows non-privileged apps to write utmp (login) info, which need root access - Versions: 1.1.6-r2 (LGPL-2.1)
libuuid
Portable uuid C library - Versions: 1.0.3 (BSD)
libvpd
Library implementation for listing vpds - Versions: 2.2.4, 2.2.5, 2.1.3 (IBM)
libxcrypt
A replacement for libcrypt with DES, MD5 and blowfish support - Versions: 2.4, 2.0 (LGPL-2)
llvm-libunwind
C++ runtime stack unwinder from LLVM - Versions: 3.9.0-r1, 5.0.0, 3.8.1, 9999, 3.9.1, 5.0.9999, 4.0.1 (|| ( UoI-NCSA MIT ))
lrmi
library for calling real mode BIOS routines under Linux - Versions: 0.10-r1 (MIT)
lwp
Light-weight process library (used by Coda) - Versions: 2.6-r1, 2.2, 2.8 (LGPL-2.1)
mars
Multicore Application Runtime System - Versions: 1.0.1 (MIT_Plus MIT)
mtdev
Multitouch Protocol Translation Library - Versions: 1.1.4, 1.1.5 (MIT)
musl
Light, fast and simple C library focused on standards-conformance and safety - Versions: 1.1.18, 1.1.16, 9999 (MIT LGPL-2 GPL-2)
musl-nscd
musl-nscd is an implementation of the NSCD protocol for the musl libc - Versions: 9999 (MIT)
ncurses
console display library - Versions: 6.0-r1, 5.9-r101 (MIT)
netbsd-csu
crtbegin.o/crtend.o from NetBSD CSU for GCC-free toolchain - Versions: 7.1 (BSD-2)
newlib
Newlib is a C library intended for use on embedded systems - Versions: 2.0.0, 2.2.0.20150423, 2.4.0, 2.1.0, 9999, 2.2.0, 2.3.0.20160104, 2.5.0 (NEWLIB LIBGLOSS GPL-2)
nss-usrfiles
NSS module to read passwd/group files from CoreOS /usr location - Versions: 2.18.1 (LGPL-2.1+)
nss_wrapper
A wrapper for the user, group and hosts NSS API - Versions: 1.1.2, 1.1.3 (BSD)
ntdb
A not-so trivial keyword/data database system - Versions: 1.0-r1 (GPL-3)
obstack-standalone
A standalone library to implement GNU libc's obstack. - Versions: 1.1 (GPL-2)
openipmi
Library interface to IPMI - Versions: 2.0.22, 2.0.18-r1, 2.0.23_rc1 (LGPL-2.1 GPL-2)
pam
Linux-PAM (Pluggable Authentication Modules) - Versions: 1.3.0, 1.2.1, 1.2.1-r1 (|| ( BSD GPL-2 ))
pinktrace
ptrace() easy wrapper library - Versions: 0.9.3 (BSD)
pwdb
Password database - Versions: 0.62-r1 (|| ( BSD GPL-2 ))
readline
Another cute console display library - Versions: 6.3_p8-r3, 7.0_p3, 5.2_p14, 4.3_p5 (GPL-3)
rvm
Recoverable Virtual Memory (used by Coda) - Versions: 1.12, 1.17-r1 (LGPL-2.1)
slang
A multi-platform programmer's library designed to allow a developer to create robust software - Versions: 2.3.0, 2.3.1a (GPL-2)
suacomp
library wrapping the interix lib-c to make it less buggy - Versions: 9999, 0.6.14 (BEER-WARE)
system-config-base
system-config-* layout package - Versions: 1-r1 (GPL-2)
talloc
Samba talloc library - Versions: 2.1.5, 2.1.10, 2.1.9 (GPL-3 LGPL-3+ LGPL-2)
tapi
Text-based Application Programming Interface - Versions: 1.30 (|| ( UoI-NCSA MIT ))
tdb
A simple database API - Versions: 1.3.8, 1.3.13, 1.3.14, 1.3.15 (GPL-3)
tevent
Samba tevent library - Versions: 0.9.32, 0.9.31-r1, 0.9.33, 0.9.34, 0.9.28 (GPL-3)
timezone-data
Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump) - Versions: 2017c, 2017a, 2017b (BSD public-domain)
uclibc
C library for developing embedded Linux systems - Versions: 0.9.33.2-r15, 0.9.33.9999, 9999 (LGPL-2)
uclibc-ng
C library for developing embedded Linux systems - Versions: 1.0.22, 1.0.26, 1.0.23, 1.0.24-r1, 1.0.20, 1.0.19, 1.0.25, 9999, 1.0.24 (LGPL-2)
uid_wrapper
A wrapper to fake privilege separation - Versions: 1.2.4, 1.2.1 (GPL-3)
zlib
Standard (de)compression library - Versions: 1.2.11, 1.2.11-r1 (ZLIB)
comments powered by Disqus